#VU1174 Resource exhaustion


Published: 2016-11-15 | Updated: 2020-05-30

Vulnerability identifier: #VU1174

Vulnerability risk: Medium

CVSSv3.1: 7.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2016-7039

CWE-ID: CWE-400

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Linux kernel
Operating systems & Components / Operating system

Vendor: Linux Foundation

Description
The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists in the IP stack due to stack consumption. A remote attacker can trigger use of the GRO path for large crafted packets, as demonstrated by packets that contain only VLAN headers, and cause the service to crash.

Mitigation
Update to version 4.8.3.

Vulnerable software versions

Linux kernel: 4.1.1 - 4.8.2


CPE

External links
http://www.openwall.com/lists/oss-security/2016/10/10/15
http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.37


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability