#VU12910 Integer overflow


Published: 2018-05-21

Vulnerability identifier: #VU12910

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2017-5340

CWE-ID: CWE-190

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
PHP
Universal components / Libraries / Scripting languages

Vendor: PHP Group

Description
The vulnerability allows a remote attacker to cause DoS condition or execute arbitrary code on the target system.

The weakness exists in zend/zend_hash.c due to mishandling certain cases that require large array allocations. A remote attacker can submit specially crafted serialized data and cause the service to crash or execute arbitrary code.

Successful exploitation of the vulnerability may result in system compromise.

Mitigation
Update to version 7.0.15 or 7.1.1.

Vulnerable software versions

PHP: 7.0.0 - 7.0.14, 7.1.0


CPE

External links
http://bugs.php.net/bug.php?id=73832


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability