#VU13993 Information disclosure


Published: 2018-07-24 | Updated: 2018-07-25

Vulnerability identifier: #VU13993

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-8037

CWE-ID: CWE-200

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache Tomcat
Server applications / Web servers

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to obtain potentially sensitive information on the target system.

The vulnerability exists due to improper handling of connection closures by the non-blocking I/O (NIO) and NIO2 connectors. A remote unauthenticated attacker can send a specially crafted request that submits malicious input, trigger bug in the tracking of connection closures, reuse user sessions in a new connection and access arbitrary data.

Mitigation
Update to version 9.0.10.

Vulnerable software versions

Apache Tomcat: 9.0.0-M9 - 9.0.9


CPE

External links
http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.10


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability