#VU18446 Input validation error


Published: 2020-03-18 | Updated: 2021-08-23

Vulnerability identifier: #VU18446

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2019-0708

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: Yes

Vulnerable software:
Windows Server
Operating systems & Components / Operating system
Windows
Operating systems & Components / Operating system

Vendor: Microsoft

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to insufficient validation of user-supplied input when processing RDP packets in Windows Remote Desktop Services. A remote unauthenticated attacker can send a series of specially crafted requests and execute arbitrary code on the target system.

Successful exploitation of vulnerability may allow an attacker to compromise vulnerable system.

Note, this vulnerability is known as BlueKeep.

In-the-wild exploitation of the vulnerability was detected on November 2, 2019.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Windows Server: 2008 - 2008 R2

Windows: 7


CPE

External links
http://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-0708
http://blog.rapid7.com/2019/09/06/initial-metasploit-exploit-module-for-bluekeep-cve-2019-0708/
http://twitter.com/GossiTheDog/status/1190654984553205761


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability