#VU19218 Improper access control in Apache Kafka


Published: 2019-07-17

Vulnerability identifier: #VU19218

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2018-17196

CWE-ID: CWE-284

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Apache Kafka
Client/Desktop applications / Messaging software

Vendor: Apache Foundation

Description

The vulnerability allows a remote attacker to gain unauthorized access to sensitive information.

The vulnerability exists due to improper security restrictions imposed by the affected software. A remote authenticated attacker with write permission on respective topics can send a crafted Produce request that is designed to bypass transaction/idempotent access control list (ACL) validation.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Apache Kafka: 0.11.0.0 - 0.11.0.3, 1.0.0 - 1.0.2, 1.1.0 - 1.1.1, 2.1.0, 2.0.0 - 2.0.1


CPE

External links
http://www.mail-archive.com/dev@kafka.apache.org/msg99277.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability