#VU22267 Server-Side Request Forgery (SSRF)


Published: 2019-10-24

Vulnerability identifier: #VU22267

Vulnerability risk: Medium

CVSSv3.1: 4.6 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N/E:U/RL:U/RC:C]

CVE-ID: CVE-2019-10472

CWE-ID: CWE-918

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Libvirt Slaves
Web applications / Modules and components for CMS

Vendor: Jenkins

Description

The disclosed vulnerability allows a remote user to perform SSRF attacks.

The vulnerability exists due to insufficient validation of user-supplied input. A remote authenticated user with Overall/Read permission can send a specially crafted HTTP request to an attacker-specified SSH server and trick the application to initiate requests to arbitrary systems, capturing credentials stored in Jenkins.

Successful exploitation of this vulnerability may allow a remote attacker gain access to sensitive data, located in the local network or send malicious requests to other servers from the vulnerable system.

Mitigation
Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

Libvirt Slaves: 1.0 - 1.8.5


CPE

External links
http://jenkins.io/security/advisory/2019-10-23/#SECURITY-1014%20(1)


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability