#VU22623 Input validation error


Published: 2019-11-10

Vulnerability identifier: #VU22623

Vulnerability risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: N/A

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Moxa EDS-405A
Server applications / SCADA systems

Vendor: Moxa

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of HTTP GET requests. A remote attacker can send an overly long HTTP GET request and crash the web service.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Moxa EDS-405A: 2.6 - 3.8


CPE

External links
http://www.moxa.com/en/support/support/security-advisory/eds-405a-series-ethernet-switches-vulnerabilities


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability