#VU24350 Information disclosure


Published: 2020-01-16 | Updated: 2020-02-24

Vulnerability identifier: #VU24350

Vulnerability risk: Low

CVSSv3.1: 2.7 [CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-6750

CWE-ID: CWE-200

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Gnome GLib
Universal components / Libraries / Libraries used by multiple products

Vendor: Gnome Development Team

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to an error within the GSocketClient in GNOME GLib when processing proxy_addr field. A remote attacker force the system to connect to a specific server using a real address instead of pre-configured proxy address and gain knowledge of the victim's real IP address.

Exploitation of the vulnerability is timing-dependent and may occur only sporadically depending on network delays.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Gnome GLib: 2.60.0 - 2.63.5


CPE

External links
http://bugzilla.suse.com/show_bug.cgi?id=1160668
http://gitlab.gnome.org/GNOME/glib/issues/1989


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability