#VU24399 Cross-site scripting in Inappbrowser


Published: 2020-01-20

Vulnerability identifier: #VU24399

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2019-0219

CWE-ID: CWE-79

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Inappbrowser
Web applications / Modules and components for CMS

Vendor: Apache Foundation

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed via a specially crafted gap-iab: URI. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary JavaScript code in the main application's webview on the Android device.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Inappbrowser: 1.5.0 - 3.0.0


CPE

External links
http://www.openwall.com/lists/oss-security/2019/11/28/1
http://lists.apache.org/thread.html/197482d5ab80c0bff4a5ec16e1b0466df38389d9a4b5331d777f14fc%40%3Cdev.cordova.apache.org%3E


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability