#VU29673 Improper Certificate Validation in Go programming language


Published: 2020-03-16 | Updated: 2020-07-13

Vulnerability identifier: #VU29673

Vulnerability risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-7919

CWE-ID: CWE-295

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Go programming language
Universal components / Libraries / Scripting languages

Vendor: Google

Description

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

Go before 1.12.16 and 1.13.x before 1.13.7 (and the crypto/cryptobyte package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attacks on clients (resulting in a panic) via a malformed X.509 certificate.

Mitigation
Install update from vendor's website.

Vulnerable software versions

Go programming language: 1.13 - 1.13.6


External links
http://groups.google.com/forum/#!forum/golang-announce
http://groups.google.com/forum/#!topic/golang-announce/Hsw4mHYc470
http://groups.google.com/forum/#!topic/golang-announce/-sdUB4VEQkA
http://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S43VLYRURELDWX4D5RFOYBNFGO6CGBBC/
http://security.netapp.com/advisory/ntap-20200327-0001/


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability