#VU29925 Stack-based buffer overflow


Published: 2020-07-15

Vulnerability identifier: #VU29925

Vulnerability risk: High

CVSSv3.1:

CVE-ID: CVE-2020-14511

CWE-ID: CWE-121

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
EDR-G902 Series
Hardware solutions / Routers & switches, VoIP, GSM, etc
EDR-G903 Series
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor: Moxa

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in the system web server. A remote unauthenticated attacker can perform malicious operation with the crafted web browser cookie, trigger stack-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

EDR-G902 Series: 5.0 - 5.4

EDR-G903 Series: 5.0 - 5.4


CPE

External links
http://ics-cert.us-cert.gov/advisories/icsa-20-196-02
http://www.moxa.com/en/support/support/security-advisory/edr-g902-g903-series-secure-routers-vulnerabilities


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability