#VU46124 Information disclosure


Published: 2020-08-28

Vulnerability identifier: #VU46124

Vulnerability risk: Low

CVSSv3.1: 3.8 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-5916

CWE-ID: CWE-200

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
BIG-IP
Hardware solutions / Firmware
BIG-IP DDHD
Hardware solutions / Firmware
BIG-IP SSLO
Hardware solutions / Firmware
BIG-IP LTM
Hardware solutions / Security hardware applicances
BIG-IP AFM
Hardware solutions / Security hardware applicances
BIG-IP Analytics
Hardware solutions / Security hardware applicances
BIG-IP APM
Hardware solutions / Security hardware applicances
BIG-IP ASM
Hardware solutions / Security hardware applicances
BIG-IP FPS
Hardware solutions / Security hardware applicances
BIG-IP GTM
Hardware solutions / Security hardware applicances
BIG-IP PEM
Hardware solutions / Security hardware applicances
BIG-IP AAM
Hardware solutions / Routers & switches, VoIP, GSM, etc
BIG-IP DNS
Hardware solutions / Routers & switches, VoIP, GSM, etc
BIG-IP Link Controller
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor: F5 Networks, Inc.

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to excessive data output by the application within the Configuration utility. A remote authenticated attacker can perform arbitrary file reads outside of the web root directory.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

BIG-IP: 15.0.0 - 15.1.0

BIG-IP LTM: 15.0.0 - 15.1.0

BIG-IP AAM: 15.0.0 - 15.1.0

BIG-IP AFM: 15.0.0 - 15.1.0

BIG-IP Analytics: 15.0.0 - 15.1.0

BIG-IP APM: 15.0.0 - 15.1.0

BIG-IP ASM: 15.0.0 - 15.1.0

BIG-IP DDHD: 15.0.0 - 15.1.0

BIG-IP DNS: 15.0.0 - 15.1.0

BIG-IP FPS: 15.0.0 - 15.1.0

BIG-IP GTM: 15.0.0 - 15.1.0

BIG-IP Link Controller: 15.0.0 - 15.1.0

BIG-IP PEM: 15.0.0 - 15.1.0

BIG-IP SSLO: 15.0.0 - 15.1.0


CPE

External links
http://support.f5.com/csp/article/K29923912


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability