#VU48150 Exposed dangerous method or function


Published: 2020-11-05

Vulnerability identifier: #VU48150

Vulnerability risk: Low

CVSSv3: 4.8 [CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-27123

CWE-ID: CWE-749

Exploitation vector: Local

Exploit availability: No

Vulnerable software:
Cisco AnyConnect Secure Mobility Client
Client/Desktop applications / Other client software

Vendor: Cisco Systems, Inc

Description

The vulnerability allows a local user to read arbitrary files on the target system.

The vulnerability exists due to an exposed interprocess communication (IPC) channel function. A local user can send a specially crafted IPC message to the AnyConnect process and read arbitrary files on the underlying operating system of the affected device.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Cisco AnyConnect Secure Mobility Client: 4.9(1095)

CPE

External links
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-anyconnect-file-read-LsvDD6Uh


Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability