#VU52379 Improper input validation in Oracle Database Server


Published: 2021-04-21

Vulnerability identifier: #VU52379

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-2234

CWE-ID: CWE-20

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Oracle Database Server
Server applications / Database software

Vendor: Oracle

Description

The vulnerability allows a remote authenticated user to manipulate data.

The vulnerability exists due to improper input validation within the Java VM in Oracle Database Server. A remote authenticated user can exploit this vulnerability to manipulate data.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Oracle Database Server: 12.1.0.2 - 19c


CPE

External links
http://www.oracle.com/security-alerts/cpuapr2021.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability