#VU54708 Heap-based buffer overflow in Adobe Acrobat and Adobe Reader


Published: 2021-07-13

Vulnerability identifier: #VU54708

Vulnerability risk: High

CVSSv3.1: 7.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-28638

CWE-ID: CWE-122

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Adobe Acrobat
Client/Desktop applications / Office applications
Adobe Reader
Client/Desktop applications / Office applications

Vendor: Adobe

Description

The vulnerability allows a remote attacker to compromise the affected system

The vulnerability exists due to a boundary condition when processing PDF files. A remote attacker can trick the victim to open a specially crafted PDF document, trigger a heap-based buffer overflow and execute arbitrary code on the system.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Adobe Acrobat: 21.001.20135 - 21.005.20148, 20.001.30020 - 20.013.20074, 17.008.30051 - 17.011.30197

Adobe Reader: 2020.001.30020 - 2020.013.20074, 2017.011.30156 - 2017.011.30197


External links
http://helpx.adobe.com/security/products/acrobat/apsb21-51.html


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability