#VU57928 Stored cross-site scripting


Published: 2021-11-04

Vulnerability identifier: #VU57928

Vulnerability risk: Low

CVSSv3.1: 5.6 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-39906

CWE-ID: CWE-79

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Gitlab Community Edition
Universal components / Libraries / Software for developers
GitLab Enterprise Edition
Universal components / Libraries / Software for developers

Vendor: GitLab, Inc

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data within the ipynb files. A remote authenticated attacker can inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Gitlab Community Edition: 13.5.0 - 14.4.0

GitLab Enterprise Edition: 13.5.0 - 14.4.0


CPE

External links
http://about.gitlab.com/releases/2021/10/28/security-release-gitlab-14-4-1-released/


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.


Latest bulletins with this vulnerability