#VU60187 Link following


Published: 2022-01-31

Vulnerability identifier: #VU60187

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: CVE-2021-44141

CWE-ID: CWE-59

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Samba
Server applications / Directory software, identity management

Vendor: Samba

Description

The vulnerability allows a remote user to gain access to sensitive information.

The vulnerability exists due to insecure link following. A remote user with ability to write files to the exported part of the file system under a share via SMB1 unix extensions or via NFS can create a symlink to determine if a file or directory exists in an area of the server file system not exported under the share definition.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Samba: 4.14.0 - 4.14.12, 4.13.0 - 4.13.17, 4.15.0 - 4.15.4, 4.12.0 - 4.12.15, 4.11.0 - 4.11.17, 4.10.0 - 4.10.18, 4.9.0 - 4.9.18, 1.9.16 - 1.9.18, 4.8.0 - 4.8.12, 4.7.0 - 4.7.12, 4.6.0 - 4.6.16, 4.5.0 - 4.5.16, 4.4.0 - 4.4.16, 4.3.0 - 4.3.13, 4.2.0 - 4.2.14, 4.1.0 - 4.1.23, 4.0.0 - 4.0.26, 3.6.0 - 3.6.25, 3.5 - 3.5.22, 3.1 - 3.1.0, 3.4 - 3.4.17, 2.2 - 2.2a, 3.3 - 3.3.16, 3.0 - 3.0.37, 3.2 - 3.2.15, 2.18.3, 2.0 - 2.0.10


CPE

External links
http://www.samba.org/samba/security/CVE-2021-44141.html


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability