#VU61810 Inconsistent interpretation of HTTP requests in Netty


Published: 2022-04-02

Vulnerability identifier: #VU61810

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-43797

CWE-ID: CWE-444

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Netty
Universal components / Libraries / Libraries used by multiple products

Vendor: Netty project

Description

The vulnerability allows a remote attacker to preform HTTP request smuggling attacks.

The vulnerability exists due to improper validation of HTTP requests when processing control chars present at the beginning / end of the header name. A remote attacker can send a specially crafted HTTP request to the server and smuggle arbitrary HTTP headers.

Successful exploitation of vulnerability may allow an attacker to poison HTTP cache and perform phishing attacks.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Netty: 4.1.0 - 4.1.70


CPE

External links
http://github.com/netty/netty/security/advisories/GHSA-wx5j-54mm-rqqq
http://github.com/netty/netty/commit/07aa6b5938a8b6ed7a6586e066400e2643897323
http://security.netapp.com/advisory/ntap-20220107-0003/


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability