#VU64051 Improper Certificate Validation in Fortinet, Inc Server applications


Published: 2022-06-08

Vulnerability identifier: #VU64051

Vulnerability risk: Medium

CVSSv3.1:

CVE-ID: CVE-2022-22305

CWE-ID: CWE-295

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
FortiOS
Operating systems & Components / Operating system
FortiManager
Server applications / IDS/IPS systems, Firewalls and proxy servers
FortiAnalyzer
Server applications / IDS/IPS systems, Firewalls and proxy servers
FortiSandbox
Server applications / DLP, anti-spam, sniffers

Vendor: Fortinet, Inc

Description

The vulnerability allows a remote attacker to perform MitM attack.

The vulnerability exists due to improper certificate validation. A remote attacker with ability to intercept traffic can perform MitM attack against the affected products and certain external peers.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

FortiOS: 6.2.0 - 6.2.10, 6.0.0 - 6.0.14, 5.6.0 - 5.6.14

FortiManager: 7.0.0 - 7.0.1, 6.2.0 - 6.2.9, 6.4.0 - 6.4.6, 6.0.0 - 6.0.11

FortiAnalyzer: 7.0.0 - 7.0.2, 6.2.0 - 6.2.9, 6.4.0 - 6.4.7, 6.0.0 - 6.0.11

FortiSandbox: 3.0.0 - 4.0.2


CPE

External links
http://fortiguard.fortinet.com/psirt/FG-IR-18-292


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability