#VU68899 NULL pointer dereference in Foxit Reader for Mac and Foxit PDF Editor for Mac (formerly PhantomPDF)


Published: 2022-11-01

Vulnerability identifier: #VU68899

Vulnerability risk: Low

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-476

Exploitation vector: Network

Exploit availability: No

Vulnerable software:
Foxit Reader for Mac
Client/Desktop applications / Office applications
Foxit PDF Editor for Mac (formerly PhantomPDF)
Client/Desktop applications / Office applications

Vendor: Foxit Software Inc.

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dereference error when handling certain JavaScripts. A remote attacker can pass specially crafted data to the application and perform a denial of service (DoS) attack.

Mitigation
Install updates from vendor's website.

Vulnerable software versions

Foxit Reader for Mac: 11.0.0.0510 - 12.0.1.0720

Foxit PDF Editor for Mac (formerly PhantomPDF): 12.0.0.0601 - 12.0.1.0720


CPE

External links
http://www.foxitsoftware.com/support/security-bulletins.html?Security+updates+available+in+Foxit+PDF+Editor+for+Mac+12.0.2+and+Foxit+PDF+Reader+for+Mac+12.0.2+2022-11-01+00%3A00%3A00


Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?


Latest bulletins with this vulnerability