Two remote code execution vulnerabilities in Adobe Acrobat and Adobe Reader

Published: 2009-05-01 00:00:00 | Updated: 2017-03-21 14:30:05
Severity High
Patch available YES
Number of vulnerabilities 2
CVSSv2 6.9 (AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:OF/RC:C)
8.1 (AV:N/AC:M/Au:N/C:C/I:C/A:C/E:H/RL:OF/RC:C)
CVSSv3 8.3 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
9.1 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H/E:H/RL:O/RC:C]
CVE ID CVE-2009-1493
CVE-2009-1492
CWE ID CWE-119
Exploitation vector Network
Public exploit Vulnerability #2 is being exploited in the wild.
Vulnerable software Adobe Reader
Adobe Acrobat
Vulnerable software versions Adobe Reader 7.1.2
Adobe Reader 7.1.1
Adobe Reader 7.1
Show more
Adobe Acrobat 7.1.2
Adobe Acrobat 7.1.1
Adobe Acrobat 7.1.0
Show more
Vendor URL Adobe
Advisory type Public

Security Advisory

1) Memory corruption

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to boundary error when processing malicious .pdf files. A remote attacker can trick the victim into opening a specially crafted PDF file that triggers calls to the customDictionaryOpen() JavaScript method with a long string in the second argument, cause memory corruption and execute arbitrary code with privileges of the current user.

Successful exploitation of the vulnerability results in compromise of vulnerable system.



Remediation

Update Adobe Reader for Linux and UNIX 7.x to version 7.1.2, 8.x to version 8.1.5, 9.x to version 9.1.1.

External links

http://www.adobe.com/support/security/advisories/apsa09-02.html
http://www.adobe.com/support/security/bulletins/apsb09-06.html

2) Memory corruption

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to boundary error when processing malicious .pdf files. A remote attacker can trick the victim into opening a specially crafted PDF file that triggers calls to the getAnnots() JavaScript method, cause memory corruption and execute arbitrary code with privileges of the current user.

Successful exploitation of the vulnerability results in compromise of vulnerable system.

Remediation

Update Adobe Reader and Adobe Acrobat 7.x to version 7.1.2.
Update Adobe Reader and Adobe Acrobat 8.x to version 8.1.5.
Update Adobe Reader and Adobe Acrobat 9.x to version 9.1.1.

External links

http://www.adobe.com/support/security/advisories/apsa09-02.html
http://www.adobe.com/support/security/bulletins/apsb09-06.html

Back to List