Remote code execution in Adobe Acrobat and Adobe Reader

Published: 2009-12-15 00:00:00 | Updated: 2016-12-19
Severity Critical
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2009-4324
Exploitation vector Network
Public exploit This vulnerability is being exploited in the wild.
Vulnerable software Adobe Reader
Adobe Acrobat
Vulnerable software versions Adobe Reader 8.0
Adobe Reader 8.1.7
Adobe Reader 8.1.6

Show more

Adobe Acrobat 8.0
Adobe Acrobat 8.1.7
Adobe Acrobat 8.1.6

Show more

Vendor URL Adobe

Security Advisory

1) Use-after-free error


The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The weakness exists due to use-after-free error in the method in Multimedia.api. A remote attacker can create a specially crafted .pdf file, trick the victim into opening it, trigger memory corruption and execute arbitrary code on the target system with privileges of the current user.

Successful exploitation of the vulnerability results in arbitrary code execution on the vulnerable system.

Note: the vulnerability was being actively exploited.


Update Adobe Reader and Adobe Acrobat 8.1.7 or earlier to version 8.2.
Update Adobe Reader and Adobe Acrobat 9.2 or earlier to version 9.3.

External links

Back to List