Input validation error in libexpat expat



Published: 2012-07-03 | Updated: 2020-08-03
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2012-1147
CWE-ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
expat
Universal components / Libraries / Libraries used by multiple products

Vendor libexpat.org

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Input validation error

EUVDB-ID: #VU33115

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2012-1147

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

readfilemap.c in expat before 2.1.0 allows context-dependent attackers to cause a denial of service (file descriptor consumption) via a large number of crafted XML files.

Mitigation

Install update from vendor's website.

Vulnerable software versions

expat: 2.0.0 - 2.0.1


CPE2.3 External links

http://expat.cvs.sourceforge.net/viewvc/expat/expat/xmlwf/readfilemap.c?r1=1.14&r2=1.15
http://lists.apple.com/archives/security-announce/2015/Dec/msg00005.html
http://sourceforge.net/projects/expat/files/expat/2.1.0/
http://sourceforge.net/tracker/?func=detail&aid=2895533&group_id=10127&atid=110127
http://trac.wxwidgets.org/ticket/11194
http://trac.wxwidgets.org/ticket/11432
http://www.securityfocus.com/bid/52379
http://www.securitytracker.com/id/1034344
http://support.apple.com/HT205637

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###