Cross-site scripting (XSS) in jQuery UI



Published: 2016-07-23 | Updated: 2021-11-20
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2016-7103
CWE-ID CWE-79
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
jQuery UI
Web applications / JS libraries

Vendor The jQuery Team

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Cross-site scripting

EUVDB-ID: #VU7277

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2016-7103

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

Vulnerability allows a remote attacker to perform XSS attacks.

The vulnerability is caused by an input validation error in jQuery UI before 1.12.0. A remote authenticated attacker can trick the victim to follow a specially specially crafted link and execute arbitrary HTML and script code in victim's browser in security context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Update to version 1.12.0

Vulnerable software versions

jQuery UI: 1.7.0 - 1.11.4


CPE2.3 External links

http://github.com/jquery/jquery-ui/commit/9644e7bae9116edaf8d37c5b38cb32b892f10ff6
http://github.com/jquery/api.jqueryui.com/issues/281
http://jqueryui.com/changelog/1.12.0/
http://nodesecurity.io/advisories/127

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###