Cross-site scripting in /wp-admin/includes/media.php script in WordPress WordPress

Published: 2016-09-07
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2016-7168
CWE ID CWE-79
Exploitation vector Network
Public exploit N/A
Vulnerable software WordPress Subscribe
Vendor WordPress.ORG

Security Advisory

This security advisory describes one low risk vulnerability.

1) Cross-site scripting in /wp-admin/includes/media.php script

Severity: Low

CVSSv3: 5.3 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2016-7168

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability is caused by incorrect filtration of input data passed via image filename in /wp-admin/includes/media.php script. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in website administrator’s browser in security context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Update your WordPress installation to one of the following versions:

3.7.x - 3.7.16
3.8.x - 3.8.16
3.9.x - 3.9.14
4.0.x - 4.0.13
4.1.x - 4.1.13
4.2.x - 4.2.10
4.3.x - 4.3.6
4.4.x - 4.4.5
4.5.x - 4.5.4
4.6.x - 4.6.1

Vulnerable software versions

WordPress: 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.7.5, 3.7.6, 3.7.7, 3.7.8, 3.7.9, 3.7.10, 3.7.11, 3.7.12, 3.7.13, 3.7.14, 3.7.15, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.8.5, 3.8.6, 3.8.7, 3.8.8, 3.8.9, 3.8.10, 3.8.11, 3.8.12, 3.8.13, 3.8.14, 3.8.15, 3.9.0, 3.9.1, 3.9.2, 3.9.3, 3.9.4, 3.9.5, 3.9.6, 3.9.7, 3.9.8, 3.9.9, 3.9.10, 3.9.11, 3.9.12, 3.9.13, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 4.0.7, 4.0.8, 4.0.9, 4.0.10, 4.0.11, 4.0.12, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.1.9, 4.1.10, 4.1.11, 4.1.12, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.2.6, 4.2.7, 4.2.8, 4.2.9, 4.3.0, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 4.3.5, 4.4.0, 4.4.1, 4.4.2, 4.4.3, 4.4.4, 4.5.1, 4.5.2, 4.5.3, 4.6

CPE External links

https://codex.wordpress.org/Version_3.7.16
https://codex.wordpress.org/Version_3.8.16
https://codex.wordpress.org/Version_3.9.14
https://codex.wordpress.org/Version_4.0.13
https://codex.wordpress.org/Version_4.1.13
https://codex.wordpress.org/Version_4.2.10
https://codex.wordpress.org/Version_4.3.6
https://codex.wordpress.org/Version_4.4.5
https://codex.wordpress.org/Version_4.5.4
https://codex.wordpress.org/Version_4.6.1

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



ImmuniWeb® AI Platform for Application Security Testing