Multiple vulnerabilities in Drupal



Published: 2017-06-23
Risk High
Patch available YES
Number of vulnerabilities 3
CVE ID CVE-2017-6922
CVE-2017-6920
CVE-2017-6921
CWE ID CWE-693
CWE-19
CWE-20
Exploitation vector Network
Public exploit Vulnerability #1 is being exploited in the wild.
Vulnerable software
Subscribe
Drupal
Web applications / CMS

Vendor Drupal

Security Advisory

1) Security restrictions bypass

Risk: Medium

CVSSv3: 6.2 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:H/RL:O/RC:C] [PCI]

CVE-ID: CVE-2017-6922

CWE-ID: CWE-693 - Protection Mechanism Failure

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass security restrictions on the target system.

The weakness exists due to insufficient file protection. A remote attacker can bypass access restrictions and view private files that have been uploaded by an anonymous user but not permanently attached to content on the site.

Successful exploitation of the vulnerability may result in access bypass.

Note: The vulnerability was being actively exploited for spam purposes.

Mitigation

Update to version 7.56 and 8.3.4.

Vulnerable software versions

Drupal: 7.1, 7.1-1.2, 7.2, 7.3, 7.4, 7.5, 7.10, 7.11, 7.12, 7.13, 7.14, 7.15, 7.16, 7.17, 7.18, 7.19, 7.20, 7.21, 7.22, 7.23, 7.24, 7.25, 7.26, 7.27, 7.28, 7.29, 7.30, 7.31, 7.32, 7.33, 7.34, 7.35, 7.36, 7.37, 7.38, 7.39, 7.40, 7.41, 7.42, 7.43, 7.44, 7.50, 7.51, 7.52, 7.53, 7.54, 7.55, 8.0, 8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.1, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.1.10, 8.2.0, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2.5, 8.2.6, 8.2.7, 8.2.8, 8.3.0, 8.3.1, 8.3.2, 8.3.3

CPE External links

https://www.drupal.org/SA-CORE-2017-003

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

Yes. This vulnerability is being exploited in the wild.

2) Arbitrary PHP code execution

Risk: High

CVSSv3: 8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2017-6920

CWE-ID: CWE-19 - Data Handling

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute PHP code on the target system.

The weakness exists due to improper handling of PHP objects by PECL YAML parser during certain operations within Drupal core. A remote attacker can send a specially crafted file and execute PHP code on the vulnerable system.

Mitigation

Update to version 8.3.4.

Vulnerable software versions

Drupal: 8.0, 8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.1, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.1.10, 8.2.0, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2.5, 8.2.6, 8.2.7, 8.2.8, 8.3.0, 8.3.1, 8.3.2, 8.3.3

CPE External links

https://www.drupal.org/SA-CORE-2017-003

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Security restrictions bypass

Risk: Medium

CVSSv3: 6.4 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2017-6921

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass security restrictions on the site.

The weakness exists due to improper validation of some fields by the file REST resource when manipulating files. If the site has the RESTful Web Services (rest) module enabled, the file REST resource is enabled and allows PATCH requests and has, a remote attacker can obtain a user account on the site with permissions to upload files and to modify the file resource.

Successful exploitation of the vulnerability results in access bypass.

Mitigation

Update to version 8.3.4.

Vulnerable software versions

Drupal: 8.0, 8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.1, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.1.10, 8.2.0, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2.5, 8.2.6, 8.2.7, 8.2.8, 8.3.0, 8.3.1, 8.3.2, 8.3.3

CPE External links

https://www.drupal.org/SA-CORE-2017-003

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###