Arch Linux update for Adobe Flash Player

Published: 2017-07-12 14:19:10 | Updated: 2017-07-12 14:19:56
Severity High
Patch available YES
Number of vulnerabilities 3
CVSSv2 3.2 (AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C)
6.9 (AV:N/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:OF/RC:C)
3.2 (AV:N/AC:M/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C)
CVSSv3 3.6 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C]
8.3 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
3.6 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C]
CVE ID CVE-2017-3080
CVE-2017-3099
CVE-2017-3100
CWE ID CWE-200
CWE-119
Exploitation vector Network
Public exploit Not available
Vulnerable software Arch Linux
Vulnerable software versions Arch Linux -
Vendor URL Arch Linux
Advisory type Public

Security Advisory

1) Security restrictions bypass

Description

The vulnerability allows a remote attacker to bypass security restrictions on the target system.

The weakness exists due to improper validation of user-supplied input. A remote attacker can send a specially crafted file, trick the victim into opening it, bypass security restrictions and obtain potentially sensitive information the system.

Successful exploitation of the vulnerability results in information disclosure.

Remediation

Update the affected package lib32-flashplugin to version 26.0.0.137-1.

External links

https://security.archlinux.org/advisory/ASA-201707-9

2) Memory corruption

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The weakness exists due to boundary error when handling malicious content. A remote attacker can send a specially crafted file, trick the victim into opening it, trigger memory corruption and execute arbitrary code with privileges of the current user.

Successful exploitation of the vulnerability may result in system compromise.

Remediation

Update the affected package lib32-flashplugin to version 26.0.0.137-1.

External links

https://security.archlinux.org/advisory/ASA-201707-9

3) Memory corruption

Description

The vulnerability allows a remote attacker to obtain potentially sensitive information on the target system.

The weakness exists due to boundary error when handling malicious content. A remote attacker can send a specially crafted file, trick the victim into opening it, trigger memory corruption and gain access to memory address.

Successful exploitation of the vulnerability may result in information disclosure.

Remediation

Update the affected package lib32-flashplugin to version 26.0.0.137-1.

External links

https://security.archlinux.org/advisory/ASA-201707-9

Back to List