Slackware Linux update for expat



Published: 2017-07-19
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2017-9233
CWE-ID CWE-611
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
expat
Universal components / Libraries / Libraries used by multiple products

Vendor libexpat.org

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Improper Restriction of XML External Entity Reference

EUVDB-ID: #VU7242

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-9233

CWE-ID: CWE-611 - Improper Restriction of XML External Entity Reference ('XXE')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to an error within entityValueInitProcessor() function while parsing malformed XML in an external entity. An attacker can take advantage of this flaw to cause a denial of service against an application using the Expat library.

Successful exploitation of the vulnerability may allow an attacker to perform a denial of service attack.

Mitigation

Update the affected package expat to version 2.2.2.

Vulnerable software versions

expat: 1.95.0 - 2.2.0


CPE2.3 External links

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2017&m=slackware-security.536169

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###