Denial of service in Apache CXF

Published: 2017-11-14
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2017-12624
CWE ID CWE-19
Exploitation vector Network
Public exploit N/A
Vulnerable software Apache CXF Subscribe
Vendor Apache Foundation

Security Advisory

This security advisory describes one low risk vulnerability.

1) Data handling

Severity: Low

CVSSv3: 4.6 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2017-12624

CWE-ID: CWE-19 - Data Handling

Description

The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists due to data handling. A remote attacker can send specially crafted message attachment header and cause the service to crash.

Mitigation

Update to version 3.2.1 or 3.1.14.

Vulnerable software versions

Apache CXF: 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.2.0

CPE External links

http://cxf.apache.org/security-advisories.data/CVE-2017-12624.txt.asc

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.