Denial of service in Digium Asterisk

Published: 2017-12-13 00:00:00
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID N/A
CVSSv3 4.6 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]
CWE ID CWE-119
Exploitation vector Network
Public exploit Not available
Vulnerable software Asterisk
Vulnerable software versions Asterisk 13.18.3
Asterisk 13.18.0
Asterisk 13.17.0
Show more
Vendor URL Digium (Linux Support Services)

Security Advisory

1) Memory corruption

Description

The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists due to boundary error when handling user-supplied input. A remote attacker can establish a call to the target system and send a specially crafted compound RTCP packet containing more than one report, trigger memory corruption and cause the application to crash.

Successful exploitation of the vulnerability results in denial of service.

Remediation

Update to version 13.18.4, 14.7.4, 15.1.4.

External links

http://downloads.asterisk.org/pub/security/AST-2017-012.html

Back to List