Command execution in Ruby

Published: 2017-12-14 00:00:00
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2017-17405
CVSSv3 8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-77
Exploitation vector Network
Public exploit N/A
Vulnerable software Ruby
Vulnerable software versions Ruby 2.4.2
Ruby 2.4.1
Ruby 2.4.0

Show more

Vendor URL Ruby

Security Advisory

1) Command injection

Description

The vulnerability allows a remote attacker to execute arbitrary commands on the target system.

The weakness exists due to flaws in the Net::FTP. A remote attacker can inject and execute arbitrary commands with elevated privileges.

Successful exploitation of the vulnerability may result in system compromise.

Remediation

Update to version 2.2.9, 2.3.6, 2.4.3 or later.

External links

https://www.ruby-lang.org/en/news/2017/12/14/net-ftp-command-injection-cve-2017-17405/

Back to List