Multiple vulnerabilities in VmWare products

Published: 2017-12-19 00:00:00
Severity High
Patch available YES
Number of vulnerabilities 4
CVE ID CVE-2017-4943
CVE-2017-4940
CVE-2017-4941
CVE-2017-4933
CVSSv3 6.8 [CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]
5.3 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C]
9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:P/RL:O/RC:C]
9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:P/RL:O/RC:C]
CWE ID CWE-264
CWE-79
CWE-843
CWE-122
Exploitation vector Network
Public exploit Public exploit code for vulnerability #3 is available.
Public exploit code for vulnerability #4 is available.
Vulnerable software vCenter Server Appliance
VMware ESXi
VMware Fusion
VMware Workstation
Vulnerable software versions vCenter Server Appliance 6.5
vCenter Server Appliance 6.0
vCenter Server Appliance 5.5
VMware ESXi 6.5
VMware ESXi 6.0
VMware ESXi 5.5
VMware Fusion 8.5.8
VMware Fusion 8.5.7
VMware Fusion 8.5.6
Show more
VMware Workstation 12.5.7
VMware Workstation 12.5.6
VMware Workstation 12.5.5
Show more
Vendor URL VMware, Inc

Security Advisory

1) Privilege escalation

Description

The vulnerability allows a local attacker to gain elevated privileges on the target system.

The weakness exists in VMware vCenter Server Appliance due to a flaw in the 'showlog' plugin. A local attacker can gain root level privileges over the appliance base OS.

Remediation

Install update from vendor's website (vCSA 6.5 U1d).

External links

https://www.vmware.com/security/advisories/VMSA-2017-0021.html

2) Stored cross-site scripting

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Remediation

Install update from vendor's website.

External links

https://www.vmware.com/security/advisories/VMSA-2017-0021.html

3) Type confusion

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists in the remote management functionality due to improper handling of Virtual Network Computing (VNC) packets. A remote attacker can send a series of VNC packets, cause a type confusion and stack overwrite to execute arbitrary code with elevated privileges.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Remediation

Install update from vendor's website.

External links

https://www.vmware.com/security/advisories/VMSA-2017-0021.html

4) Heap-based buffer overflow

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists in the remote management functionality due to improper handling of Virtual Network Computing (VNC) packets. A remote attacker can send a series of VNC packets, cause heap-based buffer overflow to execute arbitrary code with elevated privileges.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Remediation

Install update from vendor's website.

External links

https://www.vmware.com/security/advisories/VMSA-2017-0021.html

Back to List