Remote code execution in vBulletin

Published: 2017-12-19 00:00:00
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID N/A
CVSSv3 8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-20
Exploitation vector Network
Public exploit Not available
Vulnerable software vBulletin
Vulnerable software versions vBulletin 5.0
Vendor URL vBulletin

Security Advisory

1) Improper input validation

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The weakness exists in the vBulletin software package due to insufficient validation of user-supplied data. A remote attacker can send specially crafted file and execute arbitrary code with privileges of the current user.

Successful exploitation of the vulnerability may result in system compromise.

Remediation

Update to the latest version.

External links

https://www.checkpoint.com/defense/advisories/public/2017/cpai-2017-1077.html

Back to List