Memory leak in ImageMagick

Published: 2018-01-02 13:54:32
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2017-18008
CVSSv3 5.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]
CWE ID CWE-401
Exploitation vector Network
Public exploit Not available
Vulnerable software ImageMagick
Vulnerable software versions ImageMagick 7.0.7-17
Vendor URL ImageMagick.org

Security Advisory

1) Memory leak

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to memory leak within ReadPWPImage in coders/pwp.c. A remote attacker can perform a denial of service attack.


Remediation

Install update from vendor's website.

External links

https://github.com/ImageMagick/ImageMagick/issues/921

Back to List