Multiple vulnerabilities in Palo Alto PAN-OS



Published: 2018-01-10 | Updated: 2020-07-17
Risk Low
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2017-15941
CVE-2017-16878
CWE-ID CWE-79
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Palo Alto PAN-OS
Operating systems & Components / Operating system

Vendor Palo Alto Networks, Inc.

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Cross-site scripting

EUVDB-ID: #VU31364

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-15941

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

Vulnerability allows a remote attacker to perform XSS attacks.

The vulnerability is caused by an input validation error in Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and 8.0.x before 8.0.7, when the GlobalProtect gateway or portal is configured,. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in victim's browser in security context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Update to version 8.0.7.

Vulnerable software versions

Palo Alto PAN-OS: 8.0.0 - 8.0.6-h3


CPE2.3 External links

http://www.securityfocus.com/bid/102446
http://www.securitytracker.com/id/1040147
http://security.paloaltonetworks.com/CVE-2017-15941

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Cross-site scripting

EUVDB-ID: #VU31365

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2017-16878

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

Vulnerability allows a remote attacker to perform Cross-site scripting attacks.

An input validation error exists in the Captive Portal function in Palo Alto Networks PAN-OS before 8.0.7. A remote authenticated attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in victim's browser in security context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Update to version 8.0.7.

Vulnerable software versions

Palo Alto PAN-OS: 8.0.0 - 8.0.6-h3


CPE2.3 External links

http://www.securitytracker.com/id/1040148
http://security.paloaltonetworks.com/CVE-2017-16878

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###