Denial of service in Microsoft PowerShell Core

Published: 2018-03-13 22:05:11 | Updated: 2018-03-13
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2018-0875
CVSSv3 6.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]
CWE ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software PowerShell Core
Vulnerable software versions PowerShell Core 6.0.0
Vendor URL Microsoft

Security Advisory

1) Improper input validation

Description

The vulnerability allows a remote attacker to cause DoS condition on the target system.

The weakness exists in the way that .NET Core handles specially crafted requests. A remote attacker can send a small number of specially crafted requests to an .NET Core web application, trigger a hash collision and cause performance to degrade significantly enough to cause service crash.

Remediation

Install updates from vendor's website.

External links

https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2018-0875

Back to List