Denial of service in Siemens SIMATIC, SINUMERIK, and PROFINET IO

Published: 2018-03-22
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2018-4843
CWE ID CWE-20
Exploitation vector Local network
Public exploit N/A
Vulnerable software SIMATIC S7-300 Subscribe
SINUMERIK 840D
SIMATIC WinAC RTX 2010
SIMATIC S7-410
Softnet PROFINET IO for PC-based Windows systems
SINUMERIK 828D
SIMATIC S7-400 PN/DP V7
SIMATIC S7-400 PN/DP V6
SIMATIC S7-400 H
SIMATIC S7-1500 CPU
SIMATIC S7-1500 Software Controller
SIMATIC CP 443-1 Standard
SIMATIC CP 443-1 Advanced
SIMATIC CP 343-1 Standard
SIMATIC CP 343-1 Advanced
Vendor Siemens

Security Advisory

This security advisory describes one low risk vulnerability.

1) Improper input validation

Severity: Low

CVSSv3: 4.6 [CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2018-4843

CWE-ID: CWE-20 - Improper Input Validation

Description

The vulnerability allows an adjacent attacker to cause DoS condition on the target system.

The weakness exists due to insufficient validation of user-supplied input. An attacker that is located on the same Ethernet segment (OSI Layer 2) as the targeted device can respond to a PROFINET DCP request with a specially crafted PROFINET DCP packet and cause denial of service.

Mitigation

Install update from vendor's website.

Vulnerable software versions

SIMATIC S7-300: -

SINUMERIK 840D: -

SIMATIC WinAC RTX 2010: -

SIMATIC S7-410: -

Softnet PROFINET IO for PC-based Windows systems: -

SINUMERIK 828D: -

SIMATIC S7-400 PN/DP V7: -

SIMATIC S7-400 PN/DP V6: -

SIMATIC S7-400 H: -

SIMATIC S7-1500 CPU: -

SIMATIC S7-1500 Software Controller: -

SIMATIC CP 443-1 Standard: -

SIMATIC CP 443-1 Advanced: -

SIMATIC CP 343-1 Standard: -

SIMATIC CP 343-1 Advanced: -

CPE External links

https://cert-portal.siemens.com/productcert/pdf/ssa-592007.pdf

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the local network (LAN).

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.