Privilege escalation in CyberGhost

Published: 2018-05-15 16:05:57
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2018-10646
CVSSv3 8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-264
Exploitation vector Network
Public exploit Not available
Vulnerable software CyberGhost
Vulnerable software versions CyberGhost 6.5.0.3180
Vendor URL CyberGhost

Security Advisory

1) Privilege escalation

Description

The vulnerability allows a remote attacker to execute arbitrary code with elevated privileges on the target system.

The weakness exists in the "CG6Service" service due to establishing an NetNamedPipe endpoint that allows arbitrary installed applications to connect and call publicly exposed methods. The ConnectToVpnServer method accepts a connectionParams argument that provides attacker control of the OpenVpn command line. A remote attacker can specify a dynamic library plugin that should run for every new VPN connection attempt and execute arbitrary code with root privileges.

Successful exploitation of he vulnerability may result in system compromise.

Remediation

Install update from vendor's website.

External links

https://github.com/VerSprite/research/blob/master/advisories/VS-2018-023.md

Back to List