Red Hat update for ISC DHCP



Published: 2018-05-17
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2018-1111
CWE-ID CWE-77
Exploitation vector Local
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
Red Hat Enterprise Linux Server
Operating systems & Components / Operating system

Red Hat Enterprise Linux for IBM z Systems
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Scientific Computing
Operating systems & Components / Operating system

Red Hat Enterprise Linux EUS Compute Node
Operating systems & Components / Operating system

Red Hat Enterprise Linux for ARM
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Power
Operating systems & Components / Operating system

Red Hat Enterprise Linux Desktop
Operating systems & Components / Operating system

Red Hat Enterprise Linux Workstation
Operating systems & Components / Operating system

Vendor Red Hat Inc.

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Command injection

EUVDB-ID: #VU12743

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-1111

CWE-ID: CWE-77 - Command injection

Exploit availability: Yes

Description

The vulnerability allows a physical attacker to execute arbitrary commands with elevated privileges on the target system.

The weakness exists in the NetworkManager integration script due to command injection. A physical attacker can return specially crafted data via dhcp and execute arbitrary commands with root privileges.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux Server: 7 - 7.5

Red Hat Enterprise Linux for IBM z Systems: 7 - 7.5

Red Hat Enterprise Linux for Scientific Computing: 7

Red Hat Enterprise Linux EUS Compute Node: 7.5

Red Hat Enterprise Linux for ARM: 6.4

Red Hat Enterprise Linux for Power: 7 - 9

Red Hat Enterprise Linux Desktop: 7

Red Hat Enterprise Linux Workstation: 7


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:1453

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###