Red Hat update for git



Published: 2018-07-11
Risk High
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2018-11233
CVE-2018-11235
CWE-ID CWE-20
Exploitation vector Network
Public exploit Public exploit code for vulnerability #2 is available.
Vulnerable software
Subscribe
Red Hat Enterprise Linux for Power
Operating systems & Components / Operating system

Red Hat Enterprise Linux for x86_64
Operating systems & Components / Operating system

Vendor Red Hat Inc.

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Improper input validation

EUVDB-ID: #VU13048

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-11233

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to obtain potentially sensitive information on the target system.

The weakness exists due to input validation flaw in processing path names on NTFS-based systems. A remote attacker can supply specially crafted path names and read random memory contents.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for Power: 7.5

Red Hat Enterprise Linux for x86_64: 6 - 7.4


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:2147

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Improper input validation

EUVDB-ID: #VU13047

Risk: High

CVSSv3.1:

CVE-ID: CVE-2018-11235

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: Yes

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The weakness exists due to improper validation of submodule "names" supplied via the untrusted .gitmodules file when appending them to the '$GIT_DIR/modules' directory. A remote attacker can return specially crafted data to create or overwrite files on the target user's system when the repository is cloned and execute arbitrary code with elevated privileges.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for Power: 7.5

Red Hat Enterprise Linux for x86_64: 6 - 7.4


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:2147

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###