Denial of service in Cisco Unified Communications Manager IM & Presence Service

Published: 2018-08-16
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2018-0409
CWE ID CWE-126
CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software Cisco Unified Communications Manager IM & Presence Service Subscribe
Vendor Cisco Systems, Inc

Security Advisory

This security advisory describes one low risk vulnerability.

1) Improper input validation

Severity: Low

CVSSv3: 6.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2018-0409

CWE-ID: CWE-126 - Buffer Over-read

Description

The vulnerability allows a remote attacker to cause DoS condition on the target system.

The vulnerability exists in the XCP Router service due to improper validation of user-supplied input. A remote attacker can send a malicious IPv4 or IPv6 packet to an affected device on TCP port 7400, overread a buffer and cause the XCP Router service to crash and restart.

Mitigation

Update to version 12.5(0.98000.355), 12.0(1.21000.3), 11.5(1.14900.32) or 11.5(1.14900.15).

Vulnerable software versions

Cisco Unified Communications Manager IM & Presence Service: 11.5(1)

CPE External links

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180815-ucmimps-dos

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.