Red Hat update for nginx



Published: 2018-11-29
Risk Medium
Patch available YES
Number of vulnerabilities 3
CVE-ID CVE-2018-16843
CVE-2018-16844
CVE-2018-16845
CWE-ID CWE-399
CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Red Hat Enterprise Linux for x86_64
Operating systems & Components / Operating system

Vendor Red Hat Inc.

Security Bulletin

This security bulletin contains information about 3 vulnerabilities.

1) Resource management error

EUVDB-ID: #VU15745

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2018-16843

CWE-ID: CWE-399 - Resource Management Errors

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to excessive memory usage when processing HTTP/2 requests within the ngx_http_v2_module module. A remote attacker can send specially crafted HTTP/2 requests to the affected web server and consume all available memory on the system and perform a denial of service (DoS) attack.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for x86_64: 7.0 - 7.6


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:3681

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Resource management error

EUVDB-ID: #VU15744

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2018-16844

CWE-ID: CWE-399 - Resource Management Errors

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to excessive CPU usage when processing HTTP/2 requests within the ngx_http_v2_module module. A remote attacker can send specially crafted HTTP/2 requests to the affected web server and cause high CPU usage and perform a denial of service (DoS) attack.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for x86_64: 7.0 - 7.6


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:3681

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Buffer over-read

EUVDB-ID: #VU15743

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2018-16845

CWE-ID: CWE-125 - Out-of-bounds read

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information or trigger denial of service conditions.

The vulnerability exists due to a boundary condition when processing headers of MP4 files within the ngx_http_mp4_module module. A remote attacker can create a specially crafted MP4 file, trick the victim into uploading it on the server and trigger application crash or disclosure of the worker's process memory.

Successful exploitation of the vulnerability requires that nginx is compiled with support for ngx_http_mp4_module module (not a default configuration).

Mitigation

Install update from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for x86_64: 7.0 - 7.6


CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:3681

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###