Amazon Linux AMI update for curl

Published: 2018-12-07 10:05:11 | Updated: 2018-12-07
Severity High
Patch available YES
Number of vulnerabilities 2
CVE ID CVE-2018-14618
CVE-2017-8816
CVSSv3 8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-120
CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software Amazon Linux AMI
Vulnerable software versions Amazon Linux AMI 2017.03
Vendor URL Amazon Web Services, Inc.

Security Advisory

1) Buffer overflow

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists on systems with a 32-bit size_t and that use more than 2 GB of memory for the password field due to a buffer overflow in Curl_ntlm_core_mk_nt_hash() in 'lib/curl_ntlm_core.c' when handling malicious input. A remote unauthenticated attacker can send a specially crafted NTLM authentication password, trigger memory corruption and execute arbitrary code with elevated privileges.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Remediation

Update the affected packages.

i686:
    libcurl-devel-7.53.1-16.85.amzn1.i686
    curl-debuginfo-7.53.1-16.85.amzn1.i686
    libcurl-7.53.1-16.85.amzn1.i686
    curl-7.53.1-16.85.amzn1.i686

src:
    curl-7.53.1-16.85.amzn1.src

x86_64:
    curl-7.53.1-16.85.amzn1.x86_64
    libcurl-devel-7.53.1-16.85.amzn1.x86_64
    libcurl-7.53.1-16.85.amzn1.x86_64
    curl-debuginfo-7.53.1-16.85.amzn1.x86_64

External links

https://alas.aws.amazon.com/ALAS-2018-1112.html

2) Buffer overflow

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to buffer overflow in the NTLM authentication process. A remote unauthenticated attacker can use vectors involving long user and password fields, trigger memory corruption and execute arbitrary code with privileges of the current user.

Successful exploitation of the vulnerability may result in system compromise.

Remediation

Update the affected packages.

i686:
    libcurl-devel-7.53.1-16.85.amzn1.i686
    curl-debuginfo-7.53.1-16.85.amzn1.i686
    libcurl-7.53.1-16.85.amzn1.i686
    curl-7.53.1-16.85.amzn1.i686

src:
    curl-7.53.1-16.85.amzn1.src

x86_64:
    curl-7.53.1-16.85.amzn1.x86_64
    libcurl-devel-7.53.1-16.85.amzn1.x86_64
    libcurl-7.53.1-16.85.amzn1.x86_64
    curl-debuginfo-7.53.1-16.85.amzn1.x86_64

External links

https://alas.aws.amazon.com/ALAS-2018-1112.html

Back to List