Denial of service in FasterXML jackson-databind



Published: 2018-12-20 | Updated: 2019-09-16
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2018-1000873
CWE-ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
jackson-databind
Universal components / Libraries / Libraries used by multiple products

Vendor FasterXML

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Input validation error

EUVDB-ID: #VU16786

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2018-1000873

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input. A remote attacker can trick the victim into deserializing of crafted input with specifically very large values in the nanoseconds field of a time value and cause the service to crash.

Mitigation

Update to version 2.9.8.

Vulnerable software versions

jackson-databind: 2.9.0 - 2.9.7, 2.8.0 - 2.8.11.1, 2.7.0 - 2.7.9.3, 2.6.0 - 2.6.8, 2.5.0 - 2.5.5, 2.4.0 - 2.4.6.1, 2.3.0 - 2.3.5, 2.1.0 - 2.1.4


CPE2.3 External links

http://github.com/FasterXML/jackson-modules-java8/issues/90
http://github.com/FasterXML/jackson-modules-java8/pull/87

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###