Remote code execution in xterm.js

Published: 2019-01-11 18:14:58
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-0542
CVSSv3 8.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-264
Exploitation vector Network
Public exploit N/A
Vulnerable software xterm.js
Vulnerable software versions xterm.js 3.10.0
xterm.js 3.9.1
xterm.js 3.9.0

Show more

Vendor URL xterm.js

Security Advisory

1) Remote code execution

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to unspecified flaw. A remote unauthenticated attacker can execute arbitrary code with elevated privileges.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Remediation

The vulnerability has been addressed in the versions 3.8.1, 3.9.2, 3.10.1.

External links

https://github.com/xtermjs/xterm.js/releases

Back to List