Remote code execution in Adobe Photoshop

Published: 2019-03-12 14:44:02 | Updated: 2019-03-12
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-7094
CVSSv3 7.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]
CWE ID CWE-122
Exploitation vector Network
Public exploit N/A
Vulnerable software Adobe Photoshop
Vulnerable software versions Adobe Photoshop 20.0.2
Adobe Photoshop 20.0
Adobe Photoshop 19.1.7

Show more

Vendor URL Adobe

Security Advisory

1) Heap-based buffer overflow

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error. A remote attacker can use a specially crafted file to trigger heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Remediation

Install updates from vendor's website.

External links

https://helpx.adobe.com/security/products/photoshop/apsb19-15.html

Back to List