Cross-site scripting in I, Librarian

Published: 2019-04-21 02:24:06 | Updated: 2019-04-21
Severity Medium
Patch available NO
Number of vulnerabilities 1
CVE ID CVE-2019-11359
CVSSv3 5.8 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P/RL:U/RC:C]
CWE ID CWE-79
Exploitation vector Network
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software I, Librarian
Vulnerable software versions I, Librarian 4.10
Vendor URL Martin Kucej

Security Advisory

1) Cross-site scripting

Description

Vulnerability allows a remote attacker to perform XSS attacks.

The vulnerability is caused by an input validation error in display.php in I, Librarian 4.10 when processing project parameter. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in victim's browser in security context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Remediation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

External links

https://github.com/mkucej/i-librarian/issues/138