XXE attack in Apache Camel



Published: 2019-05-22
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2019-0188
CWE-ID CWE-611
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Apache Camel
Server applications / Frameworks for developing and running applications

Vendor Apache Foundation

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) XML External Entity injection

EUVDB-ID: #VU18570

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2019-0188

CWE-ID: CWE-611 - Improper Restriction of XML External Entity Reference ('XXE')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform XXE attacks.

The vulnerability exists due to usage of a third-party JSON-lib library vulnerable to XML external entity injection attacks. A remote attacker can send a specially crafted request to the affected application and read contents of arbitrary file on the system.


Mitigation

Install updates from vendor's website.

Vulnerable software versions

Apache Camel: 2.22.0 - 2.23.2


CPE2.3 External links

http://jvn.jp/en/jp/JVN71498764/index.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###