Cross-site scripting in Download Manager for WordPress

Published: 2019-06-24
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID N/A
CWE ID CWE-79
Exploitation vector Network
Public exploit N/A
Vulnerable software WordPress Download Manager Subscribe
Vendor W3 Eden

Security Advisory

This security advisory describes one low risk vulnerability.

1) Cross-site scripting

Severity: Low

CVSSv3: 5.3 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WordPress Download Manager: 1.1, 1.2, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.3, 1.4, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.5.9, 1.5.32, 1.5.33, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.9, 2.0.10, 2.0.11, 2.0.12, 2.0.13, 2.0.14, 2.0.15, 2.0.16, 2.0.17, 2.0.18, 2.0.19, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.2.7, 2.2.8, 2.2.9, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.4.7, 2.4.8, 2.4.9, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5, 2.5.6, 2.5.7, 2.5.8, 2.5.9, 2.5.91, 2.5.92, 2.5.93, 2.5.94, 2.5.95, 2.5.96, 2.5.97, 2.5.98, 2.5.99, 2.6.0, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.6.6, 2.6.7, 2.6.8, 2.6.9, 2.6.91, 2.6.92, 2.6.93, 2.6.94, 2.6.95, 2.6.96, 2.7.0, 2.7.1, 2.7.2, 2.7.3, 2.7.4, 2.7.5, 2.7.6, 2.7.7, 2.7.8, 2.7.81, 2.7.82, 2.7.83, 2.7.84, 2.7.85, 2.7.86, 2.7.87, 2.7.88, 2.7.89, 2.7.90, 2.7.91, 2.7.92, 2.7.93, 2.7.94, 2.7.95, 2.7.96, 2.8.0, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.8.5, 2.8.6, 2.8.7, 2.8.8, 2.8.9, 2.8.91, 2.8.92, 2.8.93, 2.8.94, 2.8.95, 2.8.96, 2.8.97, 2.8.98, 2.8.99, 2.9.0, 2.9.1, 2.9.2, 2.9.3, 2.9.4, 2.9.41, 2.9.42, 2.9.43, 2.9.44, 2.9.45, 2.9.46, 2.9.47, 2.9.48, 2.9.49, 2.9.50, 2.9.51, 2.9.52, 2.9.53, 2.9.54, 2.9.55, 2.9.56, 2.9.57, 2.9.58, 2.9.59, 2.9.60, 2.9.61, 2.9.62, 2.9.63, 2.9.64, 2.9.65, 2.9.66, 2.9.67, 2.9.68, 2.9.69, 2.9.70, 2.9.71, 2.9.72, 2.9.73, 2.9.74, 2.9.75, 2.9.76, 2.9.77, 2.9.78, 2.9.79, 2.9.80, 2.9.81, 2.9.82, 2.9.83, 2.9.84, 2.9.85, 2.9.86, 2.9.87, 2.9.88, 2.9.89, 2.9.90, 2.9.91, 2.9.92, 2.9.93, 2.9.94, 2.9.95, 2.9.96

CPE External links


Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



ImmuniWeb® AI Platform for Application Security Testing