Multiple vulnerabilities in Horner Automation Cscape



Published: 2019-10-18
Risk High
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2019-13541
CVE-2019-13545
CWE-ID CWE-20
CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Cscape
Universal components / Libraries / Software for developers

Vendor Horner Automation

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

1) Input validation error

EUVDB-ID: #VU21933

Risk: High

CVSSv3.1:

CVE-ID: CVE-2019-13541

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to insufficient validation of user-supplied input. A remote attacker can access sensitive information and execute arbitrary code.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Cscape: 9.90


CPE2.3 External links

http://ics-cert.us-cert.gov/advisories/icsa-19-290-02

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Out-of-bounds write

EUVDB-ID: #VU21934

Risk: High

CVSSv3.1:

CVE-ID: CVE-2019-13545

CWE-ID: CWE-787 - Out-of-bounds write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing untrusted input. A remote attacker can create a specially crafted file, trick the victim into opening it using the affected software, trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Cscape: 9.90


CPE2.3 External links

http://ics-cert.us-cert.gov/advisories/icsa-19-290-02

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###